redmine server move

From WebHostingNeeds.com
Jump to: navigation, search
yum install ruby ruby-devel rubygems -y
rsync -avz "-e ssh -p 3333" /home/redmine/  [email protected]:/home/redmine/
rsync -avz "-e ssh -p 3333" /backup/mysql/redmine/ [email protected]:/var/lib/mysql/redmine/
cd /home/redmine/
ruby script/server -e production
[[email protected] redmine]# ruby script/server -e production
Missing the i18n 0.4.2 gem. Please `gem install -v=0.4.2 i18n`
[[email protected] redmine]#


[[email protected] redmine]# ruby script/server -e production
/usr/lib/ruby/site_ruby/1.8/rubygems.rb:779:in `report_activate_error': Could not find RubyGem rack (~> 1.0.1) (Gem::LoadError)
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:214:in `activate'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:1082:in `gem'
        from /home/redmine/vendor/rails/actionpack/lib/action_controller.rb:34
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from /home/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in `require'
        from /home/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'
        from /home/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in `require'
        from /home/redmine/vendor/rails/railties/lib/commands/server.rb:2
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from script/server:3
[[email protected] redmine]#

Fixed by installing rack

gem install rack


[[email protected] redmine]# ruby script/server -e production
/usr/lib/ruby/site_ruby/1.8/rubygems.rb:779:in `report_activate_error': RubyGem version error: rack(1.5.2 not ~> 1.0.1) (Gem::LoadError)
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:214:in `activate'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:1082:in `gem'
        from /home/redmine/vendor/rails/actionpack/lib/action_controller.rb:34
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from /home/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in `require'
        from /home/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'
        from /home/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in `require'
        from /home/redmine/vendor/rails/railties/lib/commands/server.rb:2
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from script/server:3
[[email protected] redmine]#


Fixed by installing rack version 1.0.1

gem install -v=1.0.1 rack

Run again

[[email protected] redmine]# ruby script/server -e production
=> Booting WEBrick
=> Rails 2.3.5 application starting on http://0.0.0.0:3000
/home/redmine/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:119:Warning: Gem::Dependency#version_requirements is deprecated and will be removed on or after August 2010.  Use #requirement
!!! The bundled mysql.rb driver has been removed from Rails 2.2. Please install the mysql gem and try again: gem install mysql.
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require': no such file to load -- mysql (MissingSourceFile)

Fixed by installing mysql gem

yum install mysql-devel
gem install mysql

Install web server

gem install thin
gem install webrick

Test web server with

ruby script/server thin -e production



redmine

redmine init script