avconv unknown encoder libx264

From WebHostingNeeds.com
Jump to: navigation, search

When i encode video using avconv, i get error

[email protected] ~/Downloads $ avconv -ss 00:04:00 -t 00:02:00 -i BootstrapWebDesign-03.mov -crf 25.0 -c:v libx264 -c:a libfaac -ar 48000 -b:a 160k -coder 1 -threads 0 1.mp4
avconv version 0.8.10-6:0.8.10-0ubuntu0.13.10.1, Copyright (c) 2000-2013 the Libav developers
  built on Feb  6 2014 20:53:28 with gcc 4.8.1
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'BootstrapWebDesign-03.mov':
  Metadata:
    major_brand     : qt  
    minor_version   : 537199360
    compatible_brands: qt  
    creation_time   : 2013-03-14 09:07:41
  Duration: 00:07:57.07, start: 0.000000, bitrate: 348 kb/s
    Stream #0.0(eng): Audio: aac, 44100 Hz, stereo, s16, 93 kb/s
    Metadata:
      creation_time   : 2013-03-14 09:07:41
    Stream #0.1(eng): Video: h264 (Main), yuv420p, 1280x720, 251 kb/s, 30 fps, 30 tbr, 3k tbn, 6k tbc
    Metadata:
      creation_time   : 2013-03-14 09:07:41
Unknown encoder 'libx264'
[email protected] ~/Downloads $ 

Problem fixed by installing


sudo apt-get install libavcodec-extra-53

Now i get another error

Unknown encoder 'libfaac'

libfacc is not available in ubuntu. You need to install from source or use alternative libvo_aacenc.

Changed convert command and it worked.

avconv -ss 00:04:00 -t 00:02:00 -i BootstrapWebDesign-03.mov -crf 25.0 -c:v libx264 -c:a libvo_aacenc -ar 48000 -b:a 160k -coder 1 -threads 0 1.mp4

-c:a libvo_aacenc

Instead of

-c:a libfaac



avconv